ParaView, Windows and QT 5.9.1 - no menubar?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

ParaView, Windows and QT 5.9.1 - no menubar?

Aron Helser
I recently starting compiling ParaView with Qt 5.9.1 on windows, and my menubars have disappeared. I can access them with keyboard shortcuts, but all my mouseclicks are offset vertically by about the size of the missing menubar. 

Has anyone else experienced this, or have suggestions? I'm not 100% sure it's QT 5.9.1, but it seems a likely suspect.

Inline image 1
Thanks,
Aron

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ParaView, Windows and QT 5.9.1 - no menubar?

Cory Quammen-2
Ah ha, you can reproduce https://gitlab.kitware.com/paraview/paraview/issues/17499 !

We haven't made any headway as far as I know on that issue, mainly because we haven't been able to reproduce it.


On Thu, Aug 3, 2017 at 2:31 PM, Aron Helser <[hidden email]> wrote:
I recently starting compiling ParaView with Qt 5.9.1 on windows, and my menubars have disappeared. I can access them with keyboard shortcuts, but all my mouseclicks are offset vertically by about the size of the missing menubar. 

Has anyone else experienced this, or have suggestions? I'm not 100% sure it's QT 5.9.1, but it seems a likely suspect.

Inline image 1
Thanks,
Aron

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers




--
Cory Quammen
Staff R&D Engineer
Kitware, Inc.

_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ParaView, Windows and QT 5.9.1 - no menubar?

Ben Boeckel
In reply to this post by Aron Helser
On Thu, Aug 03, 2017 at 14:31:37 -0400, Aron Helser wrote:
> I recently starting compiling ParaView with Qt 5.9.1 on windows, and my
> menubars have disappeared. I can access them with keyboard shortcuts, but
> all my mouseclicks are offset vertically by about the size of the missing
> menubar.
>
> Has anyone else experienced this, or have suggestions? I'm not 100% sure
> it's QT 5.9.1, but it seems a likely suspect.

Looks like Windows 10. I've noticed Firefox looking weird there with no
title bar and the menus jammed along the top border. Maybe ParaView is
doing that too, but then drawing the titlebar anyways? Is there some
setting on the QMainWindow to make it behave properly?

--Ben
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ParaView, Windows and QT 5.9.1 - no menubar?

Aron Helser
Yes, I'm on Windows 10, compiling with VS2015. Firefox is mimicking the other browsers on Win10 - Chrome and Edge are similar.
I was using QT 5.8.0 previously, and didn't have the problem.

Hopefully this will help someone get a repro....

On Thu, Aug 3, 2017 at 2:49 PM, Ben Boeckel <[hidden email]> wrote:
On Thu, Aug 03, 2017 at 14:31:37 -0400, Aron Helser wrote:
> I recently starting compiling ParaView with Qt 5.9.1 on windows, and my
> menubars have disappeared. I can access them with keyboard shortcuts, but
> all my mouseclicks are offset vertically by about the size of the missing
> menubar.
>
> Has anyone else experienced this, or have suggestions? I'm not 100% sure
> it's QT 5.9.1, but it seems a likely suspect.

Looks like Windows 10. I've noticed Firefox looking weird there with no
title bar and the menus jammed along the top border. Maybe ParaView is
doing that too, but then drawing the titlebar anyways? Is there some
setting on the QMainWindow to make it behave properly?

--Ben


_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: ParaView, Windows and QT 5.9.1 - no menubar?

Cory Quammen-2
Aron,

Could you try downloading the 5.3 binary and see if you have the same
issue? It uses Qt 5.8.0.

I have Windows 10 on a low-resolution laptop and none of the 5.4.0 or
5.4.1 release candidates exhibit this behavior. Those builds use Qt
5.8.0.

Ken Martin reports he has Windows 10 and has built ParaView against Qt
5.9.1, but the menu bar shows up just fine.

Thanks,
Cory

On Thu, Aug 3, 2017 at 3:40 PM, Aron Helser <[hidden email]> wrote:

> Yes, I'm on Windows 10, compiling with VS2015. Firefox is mimicking the
> other browsers on Win10 - Chrome and Edge are similar.
> I was using QT 5.8.0 previously, and didn't have the problem.
>
> Hopefully this will help someone get a repro....
>
> On Thu, Aug 3, 2017 at 2:49 PM, Ben Boeckel <[hidden email]> wrote:
>>
>> On Thu, Aug 03, 2017 at 14:31:37 -0400, Aron Helser wrote:
>> > I recently starting compiling ParaView with Qt 5.9.1 on windows, and my
>> > menubars have disappeared. I can access them with keyboard shortcuts,
>> > but
>> > all my mouseclicks are offset vertically by about the size of the
>> > missing
>> > menubar.
>> >
>> > Has anyone else experienced this, or have suggestions? I'm not 100% sure
>> > it's QT 5.9.1, but it seems a likely suspect.
>>
>> Looks like Windows 10. I've noticed Firefox looking weird there with no
>> title bar and the menus jammed along the top border. Maybe ParaView is
>> doing that too, but then drawing the titlebar anyways? Is there some
>> setting on the QMainWindow to make it behave properly?
>>
>> --Ben
>
>



--
Cory Quammen
Staff R&D Engineer
Kitware, Inc.
_______________________________________________
Powered by www.kitware.com

Visit other Kitware open-source projects at http://www.kitware.com/opensource/opensource.html

Search the list archives at: http://markmail.org/search/?q=Paraview-developers

Follow this link to subscribe/unsubscribe:
http://public.kitware.com/mailman/listinfo/paraview-developers
Loading...